Jump to content


Photo

Drag & Drop & Release Red Line


  • Please log in to reply
11 replies to this topic

#1 Abner Doon

Abner Doon
  • Members
  • 21 posts
  • Gender:Male

Posted 09 September 2017 - 10:36 AM

Hello,
I have a drag & drop problem between two grids.
(a small sample project is attached)
Specifically, when I copy a row from right to left,
the red line of row movement of the right grid does not disappear after the drop on the left grid.

it looks like he's waiting for a drop on himself.

the enddrag function does not solve the problem.

Does anyone have an idea?



#2 Boki (Berg)

Boki (Berg)

    Boki (Berg)

  • Forum Admin
  • PipPipPipPipPip
  • 7,580 posts
  • Gender:Male

Posted 09 September 2017 - 11:46 AM

Hi,

Can you please re-attach your project. Link seems to be missing.
boki@bergsoft.net | LinkedIn Profile
--
BergSoft Home Page: www.bergsoft.net
Members Section: bms.bergsoft.net
Articles and Tutorials: dn.bergsoft.net (Developers Network)
--
BergSoft Facebook page
--
Send us applications made with our components and we will submit them on: www.bergsoft.net/apps.htm. Link to this page will be also set on home page too.

#3 Abner Doon

Abner Doon
  • Members
  • 21 posts
  • Gender:Male

Posted 09 September 2017 - 04:12 PM

attach file

Attached Files



#4 Abner Doon

Abner Doon
  • Members
  • 21 posts
  • Gender:Male

Posted 21 October 2017 - 06:31 PM

Really ? no idea ?



#5 Boki (Berg)

Boki (Berg)

    Boki (Berg)

  • Forum Admin
  • PipPipPipPipPip
  • 7,580 posts
  • Gender:Male

Posted 21 October 2017 - 06:52 PM

Hi,

Sorry for delay, I will go back to this.
boki@bergsoft.net | LinkedIn Profile
--
BergSoft Home Page: www.bergsoft.net
Members Section: bms.bergsoft.net
Articles and Tutorials: dn.bergsoft.net (Developers Network)
--
BergSoft Facebook page
--
Send us applications made with our components and we will submit them on: www.bergsoft.net/apps.htm. Link to this page will be also set on home page too.

#6 Boki (Berg)

Boki (Berg)

    Boki (Berg)

  • Forum Admin
  • PipPipPipPipPip
  • 7,580 posts
  • Gender:Male

Posted 05 November 2017 - 11:44 AM

Hi Abner,

For some reason all work fine now. Maybe I have already fix this issue in meanwhile.

I will release v6.0.7 very soon so you can give it a test.

Sorry again for embarrassing delay.
boki@bergsoft.net | LinkedIn Profile
--
BergSoft Home Page: www.bergsoft.net
Members Section: bms.bergsoft.net
Articles and Tutorials: dn.bergsoft.net (Developers Network)
--
BergSoft Facebook page
--
Send us applications made with our components and we will submit them on: www.bergsoft.net/apps.htm. Link to this page will be also set on home page too.

#7 Abner Doon

Abner Doon
  • Members
  • 21 posts
  • Gender:Male

Posted 08 November 2017 - 12:29 PM

Hello Boki,

I downloaded the new version.

But the problem remains the same.

When I drag a row from the right to the left grid (shifted click),

the red line remains active in the left grid. (try the sample)

And If I click on right grid to make it disappear the current line moves.

it's very embarrassing.

How do I make sure that doesn't happen?

may be my drag & drop function is not correct...

 

by the way, how to detect that a row has been moved.

There is no event on grid

tell me...



#8 Boki (Berg)

Boki (Berg)

    Boki (Berg)

  • Forum Admin
  • PipPipPipPipPip
  • 7,580 posts
  • Gender:Male

Posted 08 November 2017 - 08:41 PM

Hi,

For some reason I'm unable to reproduce. Please check attached gif screencast.

However I noticed small red dot on left side.

Until we figure how to reproduce/fix, you can maybe try to call invalidate on left grid.

Attached File  drag.gif   701.15KB   0 downloads
boki@bergsoft.net | LinkedIn Profile
--
BergSoft Home Page: www.bergsoft.net
Members Section: bms.bergsoft.net
Articles and Tutorials: dn.bergsoft.net (Developers Network)
--
BergSoft Facebook page
--
Send us applications made with our components and we will submit them on: www.bergsoft.net/apps.htm. Link to this page will be also set on home page too.

#9 Boki (Berg)

Boki (Berg)

    Boki (Berg)

  • Forum Admin
  • PipPipPipPipPip
  • 7,580 posts
  • Gender:Male

Posted 08 November 2017 - 08:41 PM

I will try to remove this dot, maybe will fix your problem too.
boki@bergsoft.net | LinkedIn Profile
--
BergSoft Home Page: www.bergsoft.net
Members Section: bms.bergsoft.net
Articles and Tutorials: dn.bergsoft.net (Developers Network)
--
BergSoft Facebook page
--
Send us applications made with our components and we will submit them on: www.bergsoft.net/apps.htm. Link to this page will be also set on home page too.

#10 Abner Doon

Abner Doon
  • Members
  • 21 posts
  • Gender:Male

Posted 09 November 2017 - 02:04 PM

Hello Boki,
I thank you for your time...

little precision to understand well!
your animated example shows a move from left to right, In addition, I don't see any row displaced.
The problem exists only by moving a row from the right grid to the left grid.
once the movement is completed, (the row is well moved) a red line remains active in the grid on the right.

I tested invalidate, but it doesn't solve the problem.



#11 Boki (Berg)

Boki (Berg)

    Boki (Berg)

  • Forum Admin
  • PipPipPipPipPip
  • 7,580 posts
  • Gender:Male

Posted 09 November 2017 - 08:53 PM

Hi,

Unfortunately, same result. I'm starting to think that there is some graphic driver problem.

I'm working on fixing this red dot error, maybe again this will solve all problems.
boki@bergsoft.net | LinkedIn Profile
--
BergSoft Home Page: www.bergsoft.net
Members Section: bms.bergsoft.net
Articles and Tutorials: dn.bergsoft.net (Developers Network)
--
BergSoft Facebook page
--
Send us applications made with our components and we will submit them on: www.bergsoft.net/apps.htm. Link to this page will be also set on home page too.

#12 Boki (Berg)

Boki (Berg)

    Boki (Berg)

  • Forum Admin
  • PipPipPipPipPip
  • 7,580 posts
  • Gender:Male

Posted 09 November 2017 - 09:51 PM

I fixed red dot (not yet uploaded) but I don't think this will change anything for you.

But, here is one event for GridView:

procedure TForm3.NxReportDestRowMoveDrop(Sender: TObject; Row, ParentRow: INxRow; CurIndex, NewIndex: Integer);
begin
  //
end;
Maybe you can put Invalidate there? I will continue searching, but so far nothing found.
boki@bergsoft.net | LinkedIn Profile
--
BergSoft Home Page: www.bergsoft.net
Members Section: bms.bergsoft.net
Articles and Tutorials: dn.bergsoft.net (Developers Network)
--
BergSoft Facebook page
--
Send us applications made with our components and we will submit them on: www.bergsoft.net/apps.htm. Link to this page will be also set on home page too.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users