Jump to content


Photo

Table change not visible in DBGrid

VirtualTable

  • Please log in to reply
1 reply to this topic

#1 TomasB

TomasB
  • Members
  • 1 posts

Posted 21 June 2024 - 03:12 PM

Hi friends,

I have a problem with showing data from table.

 

I have TDataSource with dataset TVirtualTable.

My DBGrid is connected to this datasource.

 

I'm using DBGrid.Style=stUserDefined with CustomDrawCell procedure which it's not firing !! (in this procedure I have DefaultDrawing:= true)

 

 

1/ in OnFormShow event I'm opening this table (if not tbl.Active then tbl.Open) a cleaning it (tbl.Clear)

2/ I send a few rows in table, it's visible on DBGrid

3/ I close the form

4/ next time I open the form (so tbl could be cleaned) and try to send another data, grid is showing data sended in step 2

5/ grid.datasource.dataset.refresh not working

6/ grid.Invalidate / grid.Repaint not working

 

Can someone help me ?

 

 
 

 

 



#2 Boki (Berg)

Boki (Berg)

    Boki (Berg)

  • Forum Admin
  • PipPipPipPipPip
  • 8,209 posts
  • Gender:Male

Posted 22 June 2024 - 01:31 AM

Hello TomasB,

 

Maybe you need to enable “custom” layer too inside the column. For example:

https://help.bergsof.../DrawingOptions


boki@bergsoft.net | LinkedIn Profile
--
BergSoft Home Page: www.bergsoft.net
Users Section: users.bergsoft.net
Articles and Tutorials: help.bergsoft.net (Developers Network)
--
BergSoft Facebook page
--
Send us applications made with our components and we will submit them on: www.bergsoft.net/apps.htm. Link to this page will be also set on home page too.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users