Jump to content


Photo

Column AutoEditing troubles


  • Please log in to reply
9 replies to this topic

#1 Eduard1966

Eduard1966
  • Members
  • 58 posts
  • Gender:Male

Posted 28 January 2018 - 07:56 PM

Hi Boki,

 

Using: TNextVirtualGrid6

 

Column Editing is working fine when using AutoEditing (FALSE)

 

But if I set AutoEditing to TRUE there is a lot happening.

 

- After one click Edit is started but I have set 'SecondClickEditing' to TRUE.

 

+ After ENTER you can Edit the column below, that's OK. 

 

- After ESC and then use cursor up or down the next column is directly in Edit mode and I don't want that!

 

- When you are on the last Row the ESC doesn't work anymore.

 

Can you fix this?

 

Question: Is it possible to set my own colors for Editing?

 

Regards,

Eduard.



#2 Eduard1966

Eduard1966
  • Members
  • 58 posts
  • Gender:Male

Posted 30 January 2018 - 02:10 AM

Edit:

 

If you first select column and cancel with ESC, then press ESC again the field is empty or show wrong chars.

 

Edit2:

 

ESC not working when on last row was my mistake!



#3 Eduard1966

Eduard1966
  • Members
  • 58 posts
  • Gender:Male

Posted 01 February 2018 - 07:50 AM

I have made some changes that will improve SecondClickEditing and AutoEditing.

procedure TNxCustomGrid6.SelectCell(ACol, ARow: Integer; Shift: TShiftState);
begin
  
  {...}

  { Changed }
  if (not SecondClickEditing)
    or (ActiveView.ClickOnSelected) then
  begin
    if FColumns[ACol].AutoEditing
      then EditCell(SelectedCol, SelectedRow);
  end;

end;

{ NxGridView6 }
public
  property ClickOnSelected: Boolean read FClickOnSelected;

Maybe you will add this to your NextSuite component? No harm done.

 

Now when this is fixed the only problem is when you press ESC on selected bar there you see Edit mode with a empty field?

(So look like ESC activate Edit mode with wrong field info and ESC is only to abort?)

 

Regards,



#4 Eduard1966

Eduard1966
  • Members
  • 58 posts
  • Gender:Male

Posted 13 February 2018 - 09:09 AM

Have you already take a look?



#5 Eduard1966

Eduard1966
  • Members
  • 58 posts
  • Gender:Male

Posted 18 February 2018 - 06:58 PM

Why is there no response in either good or bad news from your side?



#6 Boki (Berg)

Boki (Berg)

    Boki (Berg)

  • Forum Admin
  • PipPipPipPipPip
  • 7,645 posts
  • Gender:Male

Posted 18 February 2018 - 10:49 PM

Hi Eduard,

I will need some time to work on this issue (to investigate it properly and work on it).
boki@bergsoft.net | LinkedIn Profile
--
BergSoft Home Page: www.bergsoft.net
Members Section: bms.bergsoft.net
Articles and Tutorials: dn.bergsoft.net (Developers Network)
--
BergSoft Facebook page
--
Send us applications made with our components and we will submit them on: www.bergsoft.net/apps.htm. Link to this page will be also set on home page too.

#7 Boki (Berg)

Boki (Berg)

    Boki (Berg)

  • Forum Admin
  • PipPipPipPipPip
  • 7,645 posts
  • Gender:Male

Posted 27 February 2018 - 09:59 PM

Hello,

I got more time to work on this task.

When AutoEdit is True every next selected cell will enter editing automatically. You can move selection with arrows even without AutoEdit.

Maybe in your case SelectionDirection set to sdNone is good solution. In that case grid will enter into edit mode on Enter key.
boki@bergsoft.net | LinkedIn Profile
--
BergSoft Home Page: www.bergsoft.net
Members Section: bms.bergsoft.net
Articles and Tutorials: dn.bergsoft.net (Developers Network)
--
BergSoft Facebook page
--
Send us applications made with our components and we will submit them on: www.bergsoft.net/apps.htm. Link to this page will be also set on home page too.

#8 Eduard1966

Eduard1966
  • Members
  • 58 posts
  • Gender:Male

Posted 28 February 2018 - 12:41 PM

SelectionDirection is already set to sdNone.

 

My problem is the lack of a choice with AutoEdit (SecondClickEditing On or Off).

I prefer On so that is why I change piece of code into:

{ Changed }
  if (not SecondClickEditing)
    or (ActiveView.ClickOnSelected) then
  begin
    if FColumns[ACol].AutoEditing
      then EditCell(SelectedCol, SelectedRow);
  end;

In my Editor I use the OneClick for other selection. Thats why.

When the user wants the old AutoEdit then simply turn SecondClickEditing OFF.

I think no harm done?

 

Will you take over this code?

 

The ESC problem will than come when you have more time?

 

Regards,

Eduard.



#9 Boki (Berg)

Boki (Berg)

    Boki (Berg)

  • Forum Admin
  • PipPipPipPipPip
  • 7,645 posts
  • Gender:Male

Posted 02 March 2018 - 08:30 PM

Hi,

I will work now on ESC problem, but editing solution must be different. Maybe having ArrowsEnable property or similar that can disable arrows.
boki@bergsoft.net | LinkedIn Profile
--
BergSoft Home Page: www.bergsoft.net
Members Section: bms.bergsoft.net
Articles and Tutorials: dn.bergsoft.net (Developers Network)
--
BergSoft Facebook page
--
Send us applications made with our components and we will submit them on: www.bergsoft.net/apps.htm. Link to this page will be also set on home page too.

#10 Eduard1966

Eduard1966
  • Members
  • 58 posts
  • Gender:Male

Posted 03 March 2018 - 10:37 AM

It's a Click problem. But maybe we aren't thinking alike.

 

Suppose AutoEdit = False.

When I Click in field I can Edit. But after editing there is nothing happening. I want automatically go to next Row. This is only possible with AutoEdit on but then SecondClickEditing is not working and everywhere I Click I go into Edit mode and that's little frustrated.  :wacko: 

 

Maybe in your thought you want AutoEdit always be AutoEdit.

If so, will you add kind of goMoveNextEditRow after Edit?

 

Maybe there is already something like this but don't know where.

 

Hope you understand me. :)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users