Jump to content


Photo

TNxPageControl6 takes a while to initialize


  • Please log in to reply
2 replies to this topic

#1 AlexMex

AlexMex
  • Members
  • 12 posts

Posted 21 January 2019 - 08:11 PM

Hello Boki,

 

I often have a delphi freeze when adding the first page on TNxPageControl6 (can take sometimes up to 1 min my i7 desktop). Looks like something goes wrong inside because after that the cut/paste function (CTRL-C / CTRL-V) does not work anymore on the form.

 

Also another issue I have is when I drag a new component from the Delphi toolbar and put it on the TNxPageSheet6, control it is attached to the form and not to the page. I have to cut / paste to get it on the page. As previous issue has disabled the cut/past function, I have to close Delphi or  reboot my pc to get the cut/paste function back.

 

And finally the initial question :)

Is there a way to hide/remove the close button  from the TNxPageControl6? User can close the tabs of my wizard and that's not designed for that.

 

Regards,

Alex



#2 Boki (Berg)

Boki (Berg)

    Boki (Berg)

  • Forum Admin
  • PipPipPipPipPip
  • 7,822 posts
  • Gender:Male

Posted 22 January 2019 - 05:38 PM

Hi Alex,

1) I will definitely need mini demo project to try to solve it. So far I never experienced this problems.

2) You should just right click and pick "New Page" and new page will be added.

3) There is a VisibleButtons property where you can hide the close button.
boki@bergsoft.net | LinkedIn Profile
--
BergSoft Home Page: www.bergsoft.net
Members Section: bms.bergsoft.net
Articles and Tutorials: dn.bergsoft.net (Developers Network)
--
BergSoft Facebook page
--
Send us applications made with our components and we will submit them on: www.bergsoft.net/apps.htm. Link to this page will be also set on home page too.

#3 AlexMex

AlexMex
  • Members
  • 12 posts

Posted 22 January 2019 - 08:23 PM

Hi Boki,

 

Thank you for your answer. I miss the Visiblebuttons property :(

1/ I have tried yesterday to create a small project without reproducing the issue. As I have arround 50 grids (40 NextGrid5 / 10 NextGrid6) and more than 100 forms it will take me some time to isolate issue. I'm quite sure I was not getting this issue before starting v6 migration.

2/ Issue is not about adding a page but adding a button or a label on the sheet. When I try to place any component on the sheet it ends on the form. I have to move it back to sheet with the form explorer as cut/paste is not working due to first issue. On my small demo this issue does not appear too. I suspect this to be directly linked with first issue. I will get back to you if I can isolate the issue.

 

Regards,

Alex






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users