Jump to content


Photo

Grid in RowMoving-Mode after opening a form


  • Please log in to reply
2 replies to this topic

#1 Frank

Frank
  • Members
  • 28 posts

Posted 25 November 2022 - 08:47 PM

Hello,

 

i use your components since years and i'm very happy with these, but recently i encountered a problem.

 

I have a grid with RowMoving = true and a few rows with data. Then i open a modal form via double-click on a row. When i close the form, the grid is in "row-moving-Mode" (red line is showed), so that any click an a row, moves these row in an different place, which is not wanted.

 

The Rows should only moved by Drag&Drop (which works fine).

 

When i open the second form by a button, the grid acts normal.

 

I have a little example project (Delphi 10.4) attached, so you can (maybe) see what i mean.

 

Maybe it's a minor problem or a question of setting the properties correct.

 

Thanks in advance.

 

Frank

Attached Files



#2 Boki (Berg)

Boki (Berg)

    Boki (Berg)

  • Forum Admin
  • PipPipPipPipPip
  • 8,101 posts
  • Gender:Male

Posted 17 December 2022 - 01:07 PM

Hello,

 

Thank you for your demo. I will fix this bug for the upcoming update.


boki@bergsoft.net | LinkedIn Profile
--
BergSoft Home Page: www.bergsoft.net
Members Section: bms.bergsoft.net
Articles and Tutorials: help.bergsoft.net (Developers Network)
--
BergSoft Facebook page
--
Send us applications made with our components and we will submit them on: www.bergsoft.net/apps.htm. Link to this page will be also set on home page too.

#3 Frank

Frank
  • Members
  • 28 posts

Posted 19 December 2022 - 03:58 PM

Hello Boki,

 

thank you for the good news :)

 

Frank






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users